Access Denied on Sites after migrating SharePoint 2010 to SharePoint 2013

After migrating the Farm from SharePoint 2010 site to SharePoint 2013 platform (Under Same domain) using the “Mount-SPContentDatabase” command, users were unable to login or access denied. When grant permission again you might note that now that particular user can access the site.

And you might also have note a prefix (i:0#.w|) has been added to username.

Solution: You have to convert the authentication method of the SharePoint Web Application from Classic to Claims

This is where PowerShell becomes really nifty. You can use PowerShell to get the conversion done.

$WebApp = Get-SPWebApplication “http://WebAppURL”

Convert-SPWebApplication -Identity $WebApp -To Claims –RetainPermissions -Verbose

$WebApp.MigrateUsers($true)

For more details on Migrate from classic-mode to claims-based authentication in SharePoint 2013 you can refer this TechNet Article: http://technet.microsoft.com/en-us/library/gg251985.aspx

Happy SharePointing !!! Open-mouthed smile

Advertisements

One thought on “Access Denied on Sites after migrating SharePoint 2010 to SharePoint 2013

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s